Mein neues Notebook

Das Neue

So, mein neues Notebook ist da. Hier werde ich meine Erfahrungen mit der Installation des Betriebssystems und der Inbetriebnahme und Konfiguration behandeln. Dabei werde ich natürlich nicht jeden einzelnen Schritt erschöpfend behandeln, aber ein kleiner Erfahrungsbericht soll es schon werden. 😉
Es handelt sich bei meinem neuen Laptop um ein Wortmann Terra Mobile 1541 Pro mit folgender Ausstattung:

1x NB MOBILE 1541 15.6″ FHD 1920×1080/HM77/Docking
15.6″ FHD 16:9 (1920×1080),mit Tastatur dt.
Chipsatz Intel HM77,
RAM max.16GB DDR3 (2x Sockel frei) 1333/1600
LAN 10/100/1000,3x USB 3.0,1xUSB2,0,
SlimDVD-Brenner,
VGA, HDMI ,eSATA, UMTS-Modul optional
Docking Port,Fingerprint,Webcam 2.0MP,TPM,WOL,
Cardreader (MMC/RSMMC/SD/MiniSD/SDHC/SDXC/MS/ MS Pro/MS Duo),
Expresscard
Microphone in, Line out,
Li-Ion Akku 62WH (6 Monate Gewährleistung)
374 x 256 x 37,9mm,
2,5 Kg -OS: Windows 7/Windows 8 OPTIONAL
TERRA Logo auf Displayabdeckung

1x NB CPU Intel Core i5-3230M PPGA988/2,6GHz/Ivy
PGA988B (G2), 2.60 (3.20) GHz, 3 MB, Ivy Bridge • Dual-Core (2C/4T) mit HD 4000 Graphics (DX11) (Ivy Bridge, Chief River)

2x SO-DIMM DDR3 4GB / PC1600

1x HDNB 500.0GB Toshiba MK5061GSYN / 7200rpm / S-AT

1x ->> FreeDOS (Preload ohne Handbuch & Datenträger)

24 Monate Garantie incl. Pickup TERRA MOBILE

Wie man sieht habe ich die Standardfestplatte durch eine flottere mit 7200rpm ersetzt und das Windows durch FreeDOS ersetzt, da ich, wie bereits erwähnt, eh Linux installieren möchte. Zusätzlich zu den 24 Monaten Garantie habe ich zwei weitere Jahre Garantieerweiterung erworben, da ich jetzt schon zweimal den Fall hatte, dass nach ~3 Jahren nach und nach Defekte auftraten (geplante Obszoleszens?). Auf das optionale UMTS-Modul habe ich verzichtet.

Das Alte

Das Terra soll mein Lenovo G560 ersetzen. Dieses wäre mir von der Ausstattung her zwar noch gut genug, aber es hatte in letzter Zeit einig Defekte und ich beschloss mir ein neues zuzulegen. Hier mal die Ausstattung des alten Laptops:

# inxi -F
System:    Host: schlepptop Kernel: 3.8-1-amd64 x86_64 (64 bit) Desktop: Gnome Distro: Debian GNU/Linux jessie/sid

Machine:   System: LENOVO product: 0679 version: Lenovo G560 serial: 2378786700757 
           Mobo: LENOVO model: N/A serial: CBG3093868 Bios: LENOVO version: 29CN27WW(V2.04) date: 06/01/2010

CPU:       Dual core Intel Core i3 CPU M 350 (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 933.00 MHz 2: 933.00 MHz 3: 933.00 MHz 4: 2266.00 MHz

Graphics:  Card: Intel Core Processor Integrated Graphics Controller 
           X.org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) tty size: 80x24 Advanced Data: N/A for root 

Audio:     Card-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel Sound: ALSA ver: k3.8-1-amd64

Network:   Card-1: Broadcom BCM43225 802.11b/g/n driver: bcma-pci-bridge 
           IF: wlan0 state: up mac: --deleted--
           Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: --deleted--

Drives:    HDD Total Size: 500.1GB (56.7% used) 1: id: /dev/sda model: WDC_WD5000BEVT size: 500.1GB 

Partition: ID: / size: 451G used: 265G (62%) fs: ext4 ID: swap-1 size: 8.17GB used: 0.37GB (5%) fs: swap

Sensors:   System Temperatures: cpu: 56.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 

Info:      Processes: 199 Uptime: 5 days Memory: 1968.2/3766.6MB Client: Shell (bash) inxi: 1.9.7

Installation

Das neue Notebook wurde gerade geliefert und als erstes steht die Installation des Betriebssystems an. Installiert wird ein Debian Testing per Netinstall.

Der Laptop bootet gefühlt in einer Sekunde, was aber kein Wunder ist, da noch FreeDOS installiert ist. Nach Einlegen der Installations-CD und Strg+Alt+Entf wird diese auch gleich gebooted. Es scheint also schon mal kein UEFI/SecureBoot meine Linux-Installation zu blockieren. Zuerst sticht mir ins Auge, dass eine grafische Installation angeboten wird. Ist diese bei der Netinstall-CD neu, oder mir bisher noch nie aufgefallen? Ich werde vom Installer gleich darauf hingewiesen, dass Firmware für die Netzwerkkarten fehlt.

Meldung fehlende Firmware

Diese lade ich mir auf meinem Lenovo mittels

apt-get -t testing download firmware-iwlwifi

herunter. Die Option -t testing verwende ich, da ich auf meinem Lenovo Unstable verwende, auf meinem Terra aber Testing installieren möchte. Das heruntergeladene .deb-Paket kopiere ich auf einen USB-Stick und entpacke es, obwohl ich nicht weiß ob das Entpacken notwendig ist.
Die Firmware wird auf dem USB-Stick auch gleich erkannt und die Installation geht weiter.

Netzwerkgerät auswählen
Ich lasse den Installer die komplette Festplatte automatisch formatieren und partitionieren und treffe die üblichen Einstellungen (Benutzername, Passwörter etc.). Die Frage ob ich am Debian Popularity-Contest teilnehmen möchte bejahe ich und über tasksel wähle ich Standard-Systemwerkzeuge und Laptop. Desktop wähle ich ab, obwohl ich Gnome3 benutzen möchte, um dies später per apt-get install gnome-core zu installeren, da mir über das Metapaket zu viele Programme installiert werden, die ich nicht nutzen möchte (z.B. Rhythmbox, dem ich Clementine vorziehe).
Da es sich um die Netinstall-CD handelt werden alle Pakete außer einem minimalen Basissystem direkt in der aktuellen Version von den Debian-Servern geladen.
Die Installation lief erfahrungsgemäß ohne Probleme durch.

Konfiguration

Ich möchte niemanden mit einer pedantischen Auflistung aller Schritte, die ich durchgeführt habe langweilen deshalb werde ich hier exemplarisch ein paar Worte zur Einrichtung verlieren. Zuerst stelle ich mein Backup per rsync wieder her. Dabei verzichte ich darauf den home-Ordner komplett zurückzusichern sondern nutze die Gelegenheit wieder ohne “Altlasten” mit frischen Konfigurationen zu starten und stelle nur die Daten von Ordnern wie Dokumente, Musik, Bilder und ausgewählte Konfigurationen (z.B. .mozilla, .icedove, .gnupg) wieder her.

Da ich bei Programmen wie Iceweasel und Icedove gerne die aktuellen Versionen des Upstreams benutze füge ich auch die Releases Unstable und Experimental zu meiner /etc/apt/sources.list hinzu. Um nicht mein ganzes System auf Unstable zu upgraden sorge ich per apt-pinning dafür, dass standardmäßig weiter aus Testing installiert wird und füge für Pakete wie Icedove und Iceweasel explizit Ausnahmeregeln in der /etc/apt/preferences hinzu.

Hier meine Quellen:

# /etc/apt/sources.list

deb http://ftp.de.debian.org/debian/ testing main non-free contrib
#deb-src http://ftp.de.debian.org/debian/ testing main non-free contrib

deb http://security.debian.org/ testing/updates main contrib non-free
#deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://www.deb-multimedia.org/ testing main non-free

deb http://ftp.de.debian.org/debian/ unstable main non-free contrib
#deb-src http://ftp.de.debian.org/debian/ unstable main non-free contrib

deb http://ftp.de.debian.org/debian/ experimental main non-free contrib
#deb-src http://ftp.de.debian.org/debian/ experimental main non-free contrib

Und hier mein, zugegeben ungewöhnliches, Pinning:

# /etc/apt/preferences

Package: *
Pin: release o=debian,a=testing
Pin-Priority: 900

Package: *
Pin: release o=debian,a=unstable
Pin-Priority: 600

Package: *
Pin: release o=debian,a=experimental
Pin-Priority: 550

Package: *
Pin: origin www.deb-multimedia.org
Pin-Priority: 100

Package: iceweasel
Pin: release o=debian
Pin-Priority: 995

Package: iceweasel-l10n-de
Pin: release o=debian
Pin-Priority: 995

Package: icedove
Pin: release o=debian
Pin-Priority: 995

Package: icedove-l10n-de
Pin: release o=debian
Pin-Priority: 995

Ansonsten verlief die Einrichtung sehr unspektakulär. Alles läuft ohne Verrenkungen out-of-the-box, die einzige unfreie Firmware, die benötigt wurde, war firmware-iwlwifi welche schon im Installer hinzugefügt wurde. Ansonsten funktioniert der Ton (OnBoard, Stereoanlage über USB-DAC, und USB-Boxen in der Küche), Grafik, LAN, WLAN, Bluetooth und Webcam. Mir fällt gar nicht mehr ein was ich noch testen könnte.
Lediglich für meinen DVB-T Stick musste ich manuell eine Firmware (gefunden bei linuxtv.org) herunterladen und nach /lib/firmware/ kopieren.

# lsusb
Bus 002 Device 013: ID 14aa:0201 WideView Technology Inc. AVermedia/Yakumo/Hama/Typhoon DVB-T USB2.0 (cold)

Eine Bewertung über Haptik, Wertigkeit etc. werde ich vermutlich erst in ein paar Tagen treffen können, da solche Dinge gerade am ersten Tag etwas ungewohnt sind (vor allem die Tastatur). Dann werde ich wohl auch noch ein paar Bilder schießen und hochladen.
Fürs erste muss der inxi-Output genügen:

System: Host: schlepptop Kernel: 3.2.0-4-amd64 x86_64 (64 bit) Desktop: Gnome Distro: Debian GNU/Linux jessie/sid

Machine: Mobo: CLEVO model: W25CEW Bios: American Megatrends version: 4.6.5 date: 11/08/2012

CPU: Dual core Intel Core i5-3230M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz 3: 1200.00 MHz 4: 1200.00 MHz

Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
X.org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) tty size: 80×24 Advanced Data: N/A for root

Audio: Card-1: Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
Card-2: Texas Instruments Speakers driver: USB Audio
Sound: Advanced Linux Sound Architecture ver: 1.0.24

Network: Card-1: Intel 82579V Gigabit Network Connection driver: e1000e
IF: eth0 state: down mac: –deleted–
Card-2: Intel Centrino Wireless-N 2230 driver: iwlwifi
IF: wlan0 state: up mac: –deleted–

Drives: HDD Total Size: 1500.3GB (51.3% used) 1: id: /dev/sda model: TOSHIBA_MK5061GS size: 500.1GB
2: id: /dev/sdb model: 10EAVS_External size: 1000.2GB

Partition: ID: / size: 443G used: 180G (43%) fs: ext4 ID: swap-1 size: 16.93GB used: 0.00GB (0%) fs: swap

Sensors: System Temperatures: cpu: 48.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A

Info: Processes: 186 Uptime: 3:08 Memory: 2155.6/7886.2MB Client: Shell (bash) inxi: 1.9.7

Teilen: FB | G+ | TW | E-Mail

Hinterlasse einen Kommentar oder diskutiere im OSBN-Chat.

In den Kommentaren können folgende Formatierungen genutzt werden.